dependency_visitor 1.0.1 icon indicating copy to clipboard operation
dependency_visitor: ^1.0.1 copied to clipboard

Visits root package, transitive and immediate dependencies in order to search given files.

[1.0.1] - 5th of September 2021 #

  • Updating packages' versions

[1.0.0] - 23th of March 2021 #

  • Null safety support
  • Upgrade dependencies

[0.1.5] - 31th of August 2020 #

  • DependencyVisitor: remove deprecated field: includeRoot

[0.1.4] - 31th of August 2020 #

  • DependencyVisitor: add ability to define search order (get order from the dependencyTypes field)
  • DependencyType: new value: DependencyType.root
  • DependencyFile: new field: absolutePath

[0.1.3] - 17th of August 2020 #

  • Add ability to search multiple files

[0.1.2] - 14th of August 2020 #

[0.1.1] - 14th of August 2020 #

  • Update homepage field in pubspec.yaml
  • Example: Move main.dart from bin directory to lib directory
  • Support multiple platforms: replace dart:io with universal_io
  • Minor code updates

[0.1.0] - 14th of August 2020 #

  • Create basic classes
  • Write documentation
  • Use effective_dart
  • Create tests
1
likes
130
pub points
4%
popularity

Publisher

unverified uploader

Visits root package, transitive and immediate dependencies in order to search given files.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

effective_dart, equatable, path, pubspec_lock_reader, universal_io, yaml

More

Packages that depend on dependency_visitor