dependency_validator 2.0.1
dependency_validator: ^2.0.1 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Checks for missing, under-promoted, over-promoted, and unused dependencies.

14
likes
80 / 110
pub points
84 %
popularity

We analyzed this package on Mar 1, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 4 API elements (75.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dependency_validator/dependency_validator.dart that imports:
  • package:dependency_validator/src/utils.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

bin/dependency_validator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/dependency_validator.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.5.01.6.02.0.0
build_config^0.4.20.4.60.4.6
checked_yaml^1.0.01.0.42.0.0
glob^1.2.01.2.02.0.0
json_annotation^3.0.03.1.14.0.0
logging^0.11.3+10.11.41.0.0
package_config^1.9.31.9.32.0.0
path^1.4.21.7.01.8.0
pub_semver^1.4.11.4.42.0.0
pubspec_parse^0.1.50.1.80.1.8
yaml^2.1.132.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.5.0
charcode-1.1.31.2.0
collection-1.14.131.15.0
file-5.2.16.1.0
intl-0.16.10.17.0
js-0.6.20.6.3
meta-1.2.41.3.0
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
pedantic-1.9.21.10.0
source_span-1.7.01.8.1
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `^1.5.0` on args does not support the stable version `2.0.0`, that was published 23 days ago.

When args is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^1.0.0` on checked_yaml does not support the stable version `2.0.0`, that was published 2 days ago.

When checked_yaml is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions checked_yaml to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Dart 2.10.5.

14
likes
80
pub points
84%
popularity

Publisher

workiva.com

Checks for missing, under-promoted, over-promoted, and unused dependencies.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

args, build_config, checked_yaml, glob, json_annotation, logging, package_config, path, pub_semver, pubspec_parse, yaml

More

Packages that depend on dependency_validator