deepar_flutter 0.0.5 copy "deepar_flutter: ^0.0.5" to clipboard
deepar_flutter: ^0.0.5 copied to clipboard

Official Flutter SDK for DeepAR

32
likes
125/ 160
pub points
83%
popularity

We analyzed this package 2 days ago, and awarded it 125 pub points (of a possible 160):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

Repository URL doesn't exist.

At the time of the analysis https://github.com/DeepARSDK/deepar-flutter-plugin was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: deepar_flutter,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:1:40

  ╷
1 │ <p>This plugin is the official SDK for <a href="http://deepar.ai">DeepAR</a>. Platforms supported: Android &amp; iOS.</p>
  │                                        ^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

30 out of 33 API elements (90.9 %) have documentation comments.

Some symbols that are missing documentation: deepar_flutter, deepar_flutter.DeepArPreview.deepArController, deepar_flutter.DeepArPreview.onViewCreated.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:deepar_flutter/deepar_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:deepar_flutter/deepar_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:deepar_flutter/deepar_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:deepar_flutter/deepar_flutter.dart that declares support for platforms: Android, iOS.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
permission_handler ^10.0.0 10.4.5 11.3.1
vector_math any 2.1.4 2.1.4
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
permission_handler_android - 10.3.6 12.0.7
permission_handler_apple - 9.1.4 9.4.5
permission_handler_platform_interface - 3.12.0 4.2.1
permission_handler_windows - 0.1.3 0.2.1
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^10.0.0` on permission_handler does not support the stable version `11.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.