ddp 0.0.13
ddp: ^0.0.13 copied to clipboard

MeteorJS DDP library for Dart.

3
likes
50 / 130
pub points
65 %
popularity

We analyzed this package on May 7, 2021, and awarded it 50 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 6 out of 162 API elements (3.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:ddp/ddp.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: The value of the field '_timeout' isn't used.

lib/ddp.dart:26:12

   ╷
26 │   Duration _timeout;
   │            ^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/ddp.dart

INFO: The value of the field '_serverId' isn't used.

lib/ddp_client.dart:43:10

   ╷
43 │   String _serverId;
   │          ^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/ddp_client.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
tuple^1.0.21.0.32.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
quiver-2.1.53.0.1
stack_trace-1.10.01.10.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.2` on tuple does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions tuple to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=1.8.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

3
likes
50
pub points
65%
popularity

MeteorJS DDP library for Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

bard.guo@gmail.com

License

MIT (LICENSE)

Dependencies

tuple

More

Packages that depend on ddp