date_range_picker 1.0.6
date_range_picker: ^1.0.6 copied to clipboard

Flutter Android iOS web

Date Range Pickers use a dialog window to select a range of date on mobile.

68
likes
80 / 110
pub points
98 %
popularity

We analyzed this package on Jan 16, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 31 out of 36 API elements (86.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
10 / 30

10/30 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

WARNING: Missing case clause for 'linux'.

lib/date_range_picker.dart:1051:5

     ╷
1051 │     switch (Theme.of(context).platform) {
     │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
     ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/date_range_picker.dart

WARNING: Missing case clause for 'macOS'.

lib/date_range_picker.dart:1051:5

     ╷
1051 │     switch (Theme.of(context).platform) {
     │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
     ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/date_range_picker.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.51.1.0-nullsafety.5
collection-1.15.0-nullsafety.51.15.0-nullsafety.5
meta-1.3.0-nullsafety.61.3.0-nullsafety.6
typed_data-1.3.0-nullsafety.51.3.0-nullsafety.5
vector_math-2.1.0-nullsafety.52.1.0-nullsafety.5

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

68
likes
80
pub points
98%
popularity

Date Range Pickers use a dialog window to select a range of date on mobile.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

anic.dh@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on date_range_picker