datapack_tools 0.1.3 icon indicating copy to clipboard operation
datapack_tools: ^0.1.3 copied to clipboard

Custom Tools for objD by Stevertus

0
likes
10/ 140
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 10 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
0 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure.

Update the homepage field and use a secure (https) URL.

0/5 points: Provide a valid README.md

README.md is empty.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

No CHANGELOG.md found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: MSG : Resolving dependencies...
MSG : Logs written to /tmp/tool-envSCXVTY/pub-cache-dirKTETXM/log/pub_log.txt.

stderr: FINE: Pub 2.18.4
SLVR: fact: datapack_tools is 0.1.3
SLVR: derived: datapack_tools
SLVR: fact: datapack_tools depends on objd ^3.0.2
SLVR: fact: datapack_tools depends on objd_gui ^0.0.1-beta.1
SLVR:   selecting datapack_tools
SLVR:   derived: objd_gui ^0.0.1-beta.1
SLVR:   derived: objd ^3.0.2
IO  : Get versions from https://pub.dartlang.org/api/packages/objd.
IO  : Get versions from https://pub.dartlang.org/api/packages/objd_gui.
IO  : HTTP GET https://pub.dartlang.org/api/packages/objd
    | Accept: application/vnd.pub.v2+json
    | user-agent: Dart pub 2.18.4
IO  : HTTP GET https://pub.dartlang.org/api/packages/objd_gui
    | Accept: application/vnd.pub.v2+json
    | user-agent: Dart pub 2.18.4
IO  : Get versions from https://pub.dartlang.org/api/packages/ansicolor.
IO  : Get versions from https://pub.dartlang.org/api/packages/archive.
IO  : Get versions from https://pub.dartlang.org/api/packages/gson.
IO  : HTTP GET https://pub.dartlang.org/api/packages/ansicolor
[...]
    | package:pub/src/solver/version_solver.dart 96:11     VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                           Future.catchError
    | package:pub/src/utils.dart 109:52                    captureErrors.wrappedCallback
    | package:stack_trace                                  Chain.capture
    | package:pub/src/utils.dart 122:11                    captureErrors
    | package:pub/src/command.dart 189:13                  PubCommand.run
    | package:args/command_runner.dart 209:27              CommandRunner.runCommand
    | package:dartdev/dartdev.dart 231:30                  DartdevRunner.runCommand
    | package:args/command_runner.dart 119:25              CommandRunner.run.<fn>
    | dart:async                                           new Future.sync
    | package:args/command_runner.dart 119:14              CommandRunner.run
    | package:dartdev/dartdev.dart 66:29                   runDartdev
    | /b/s/w/ir/x/w/sdk/pkg/dartdev/bin/dartdev.dart 11:9  main
---- End log transcript ----
IO  : Writing 102021 characters to text file /tmp/tool-envSCXVTY/pub-cache-dirKT[...]
IO  : HTTP GET https://pub.dartlang.org/api/packages/meta
    | Accept: application/vnd.pub.v2+json
    | user-agent: Dart pub 2.18.4

icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 393 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'leftEvent.dart'.

lib/core.dart:10:8

   ╷
10 │ export 'leftEvent.dart';
   │        ^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/core.dart

ERROR: Target of URI doesn't exist: 'package:objd/core.dart'.

lib/core.dart:11:8

   ╷
11 │ import 'package:objd/core.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/core.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
Because datapack_tools depends on objd ^3.0.2 which doesn't match any versions, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.21.21, Dart 2.18.4.

0
likes
10
pub points
0%
popularity

Publisher

verified publisher iconredstonecube.net

Custom Tools for objD by Stevertus

Dependencies

objd, objd_gui

More

Packages that depend on datapack_tools