datapack_tools 0.1.3

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  datapack_tools: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:datapack_tools/core.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
15
Overall:
Weighted score of the above. [more]
12
Learn more about scoring.

We analyzed this package on May 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: Because datapack_tools depends on objd ^3.0.2 which doesn't match any versions, version solving failed.

Health suggestions

Format lib/core.dart.

Run dartfmt to format lib/core.dart.

Format lib/src/Attribute.dart.

Run dartfmt to format lib/src/Attribute.dart.

Format lib/src/CustomClickEvent.dart.

Run dartfmt to format lib/src/CustomClickEvent.dart.

Fix additional 5 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/Explosion.dart (Run dartfmt to format lib/src/Explosion.dart.)
  • lib/src/FireWork.dart (Run dartfmt to format lib/src/FireWork.dart.)
  • lib/src/JoinEvent.dart (Run dartfmt to format lib/src/JoinEvent.dart.)
  • lib/src/Sidebar.dart (Run dartfmt to format lib/src/Sidebar.dart.)
  • lib/src/advancement.dart (Run dartfmt to format lib/src/advancement.dart.)

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and datapack_tools.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0