datadome 1.1.0 copy "datadome: ^1.1.0" to clipboard
datadome: ^1.1.0 copied to clipboard

A DataDome integration for Flutter.

2
likes
130/ 160
pub points
33%
popularity

We analyzed this package 42 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/DataDome/datadome-flutter/issues was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

6 out of 9 API elements (66.7 %) have documentation comments.

Some symbols that are missing documentation: datadome, datadome.DataDome, datadome.DataDome.key.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:datadome/datadome.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:datadome/datadome.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:datadome/datadome.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:datadome/datadome.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'describeEnum' is deprecated and shouldn't be used. Use the `name` getter on enums instead. This feature was deprecated after v3.14.0-2.0.pre.

lib/datadome.dart:103:17

    ╷
103 │       'method': describeEnum(method),
    │                 ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/datadome.dart

lib/datadome.dart doesn't match the Dart formatter.

To format your files run: dart format .

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
http ^0.13.3 0.13.6 1.2.2
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
http_parser - 4.0.2 4.1.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.3` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.