database_adapter_elasticsearch 0.2.2
database_adapter_elasticsearch: ^0.2.2 copied to clipboard

Adapter between 'package:database' and Elasticsearch, a full-featured text search engine based on Apache Lucene.

3
likes
90/ 130
pub points
11%
popularity

We analyzed this package on Sep 23, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 5 out of 30 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_value>=5.0.0 <8.0.07.1.08.1.2
collection^1.14.01.15.01.15.0
database^0.3.20.3.30.3.3
meta^1.1.01.7.01.7.0
universal_io>=0.8.5 <2.0.01.0.22.0.4
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.8.22.8.2
built_collection-4.3.25.1.1
charcode-1.3.11.3.1
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.0
fixnum-0.10.111.0.0
html-0.14.0+40.15.0
matcher-0.12.110.12.11
path-1.8.01.8.0
protobuf-1.1.42.0.0
quiver-2.1.53.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
universal_html-1.2.42.0.8
zone_local-0.1.20.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=5.0.0 <8.0.0` on built_value does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions built_value to update the constraint.

The constraint `>=0.8.5 <2.0.0` on universal_io does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions universal_io to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Dart 2.14.1.

3
likes
90
pub points
11%
popularity

Publisher

dint.dev

Adapter between 'package:database' and Elasticsearch, a full-featured text search engine based on Apache Lucene.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

built_value, collection, database, meta, universal_io

More

Packages that depend on database_adapter_elasticsearch