data_cache_manager 1.0.0+1
data_cache_manager: ^1.0.0+1 copied to clipboard

A Flutter cache manager plugin for storing and managing Dart data types.

1
likes
120 / 130
pub points
54 %
popularity

We analyzed this package on Aug 3, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 85 out of 105 API elements (81.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:data_cache_manager/data_cache_manager.dart that declares support for platforms: Android, iOS
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
copy_with_extension>=2.0.0 <2.1.02.0.22.0.2
equatable>=2.0.0 <2.1.02.0.32.0.3
flutterflutter0.0.00.0.0
json_annotation>=4.0.0 <4.1.04.0.14.1.0
ntp>=2.0.0 <2.1.02.0.02.0.0
path>=1.8.0 <1.9.01.8.01.8.0
sqflite>=2.0.0 <2.1.02.0.0+32.0.0+3
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.7.0
sky_engine-0.0.990.0.99
synchronized-3.0.03.0.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=4.0.0 <4.1.0` on json_annotation does not support the stable version `4.1.0`, that was published 20 days ago.

When json_annotation is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions json_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

1
likes
120
pub points
54%
popularity

A Flutter cache manager plugin for storing and managing Dart data types.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

copy_with_extension, equatable, flutter, json_annotation, ntp, path, sqflite

More

Packages that depend on data_cache_manager