dash_kit_core 2.1.3
dash_kit_core: ^2.1.3 copied to clipboard

The core component for DashKit that provides basic architecture components

5
likes
80 / 130
pub points
61 %
popularity

We analyzed this package on Aug 3, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 54 API elements (7.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
The current Dart SDK version is 2.13.4.

Because test >=1.16.0-nullsafety.19 <1.16.6 depends on test_api 0.2.19 and test >=1.15.5 <1.16.0-nullsafety depends on test_api 0.2.18+1, test >=1.15.5 <1.16.0-nullsafety or >=1.16.0-nullsafety.19 <1.16.6-∞ requires test_api 0.2.18+1 or 0.2.19.
And because test >=1.15.3 <1.15.5 depends on test_api 0.2.18, test >=1.15.3 <1.16.0-nullsafety or >=1.16.0-nullsafety.19 <1.16.6-∞ requires test_api 0.2.18 or 0.2.18+1 or 0.2.19.
And because test >=1.16.0-nullsafety.18 <1.16.0-nullsafety.19 depends on test_api 0.2.19-nullsafety.7 and every version of flutter_test from sdk depends on test_api 0.3.0, test >=1.15.3 <1.16.0-nullsafety or >=1.16.0-nullsafety.18 <1.16.6-∞ is incompatible with flutter_test from sdk.
And because test >=1.16.0-nullsafety <1.16.0-nullsafety.8 requires SDK version >=2.10.0-0 <2.12.0 and test >=1.16.6 depends on webkit_inspection_protocol ^1.0.0, if flutter_test any from sdk and test >=1.15.3 <1.16.0-nullsafety.8 or >=1.16.0-nullsafety.18 then webkit_inspection_protocol ^1.0.0.
And because test >=1.16.0-nullsafety.8 <1.16.0-nullsafety.18 depends on path >=1.8.0-nullsafety <1.8.0 and webkit_inspection_protocol >=1.0.0 depends on logging ^1.0.0, if flutter_test any from sdk and test >=1.15.3 then path >=1.8.0-nullsafety <1.8.0 or logging ^1.0.0.
And because every version of flutter_test from sdk depends on path 1.8.0 and async_redux 7.0.2 depends on logging ^0.11.4, one of flutter_test any from sdk or test >=1.15.3 or async_redux 7.0.2 must be false.
And because no versions of async_redux match >7.0.2 <8.0.0 and dash_kit_core depends on async_redux ^7.0.2, flutter_test from sdk is incompatible with test >=1.15.3.
So, because dash_kit_core depends on both flutter_test any from sdk and test ^1.15.4, version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

5
likes
80
pub points
61%
popularity

The core component for DashKit that provides basic architecture components

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

async_redux, built_collection, flutter

More

Packages that depend on dash_kit_core