darwin_gen 1.1.0-alpha.12 copy "darwin_gen: ^1.1.0-alpha.12" to clipboard
darwin_gen: ^1.1.0-alpha.12 copied to clipboard

discontinued
SDKDart

Code generator for the base darwin_sdk package of the darwin framework

0
likes
90/ 160
pub points
13%
popularity

We analyzed this package 37 hours ago, and awarded it 90 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

7 out of 117 API elements (6.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: darwin_gen.BaseServiceBuilder, darwin_gen.BaseServiceBuilder.BaseServiceBuilder, darwin_gen.BaseServiceBuilder.generateDescriptor, darwin_gen.BaseServiceBuilder.generateSubject, darwin_gen.BaseServiceResults.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:darwin_gen/darwin_gen.dart that imports:
  • package:darwin_gen/src/service_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform iOS

Because:

  • package:darwin_gen/darwin_gen.dart that imports:
  • package:darwin_gen/src/service_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/type_checker.dart that imports:
  • dart:mirrors
Package not compatible with platform Web

Because:

  • package:darwin_gen/darwin_gen.dart that imports:
  • package:darwin_gen/src/service_generator.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 18 issues. Showing the first 2:

WARNING: Unused import: 'dart:async'.

lib/src/adapters/service_adapter.dart:17:8

   ╷
17 │ import 'dart:async';
   │        ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/adapters/service_adapter.dart

WARNING: Unused import: 'dart:convert'.

lib/src/adapters/service_adapter.dart:18:8

   ╷
18 │ import 'dart:convert';
   │        ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/adapters/service_adapter.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer >=2.0.0 <6.0.0 5.13.0 6.7.0
build >=2.0.0 <3.0.0 2.4.1 2.4.1
code_builder >=4.3.0 <5.0.0 4.10.0 4.10.0
collection >=1.15.0 <2.0.0 1.19.0 1.19.0
crypto >=3.0.0 <4.0.0 3.0.3 3.0.3
dart_style >=2.2.4 <3.0.0 2.3.2 2.3.6
darwin_eventbus ^1.1.0-alpha.4 1.1.0-alpha.4 1.1.0-alpha.4
darwin_injector ^1.1.0-alpha.1 1.1.0-alpha.1 1.1.0-alpha.1
darwin_sdk ^1.1.0-alpha.12 1.1.0-alpha.12 1.1.0-alpha.12
glob >=2.0.0 <3.0.0 2.1.2 2.1.2
lyell ^0.0.2 0.0.3 1.1.0
lyell_gen ^0.2.0 0.2.0+3 1.3.1
path >=1.8.0 <2.0.0 1.8.3 1.9.0
pubspec ^2.3.0 2.3.0 2.3.0
recase ^4.1.0 4.1.0 4.1.0
source_gen >=1.0.0 <=2.0.0 1.5.0 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 72.0.0
ansi_styles - 0.3.2+1 0.3.2+1
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
built_collection - 5.1.1 5.1.1
built_value - 8.9.2 8.9.2
convert - 3.1.1 3.1.1
duffer - 1.2.5 2.3.2
file - 7.0.0 7.0.0
fixnum - 1.1.0 1.1.0
logging - 1.1.1 1.2.0
matcher - 0.12.16+1 0.12.16+1
meta - 1.15.0 1.15.0
mutex - 3.1.0 3.1.0
package_config - 2.1.0 2.1.0
pub_semver - 2.1.4 2.1.4
quiver - 3.2.1 3.2.1
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.2 0.7.2
typed_data - 1.3.2 1.3.2
uri - 1.0.0 1.0.0
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `>=2.0.0 <6.0.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.0.2` on lyell does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions lyell to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 1 error:

  • UNDEFINED_GETTER - lib/src/handlers.dart:89:33 - The getter 'element2' isn't defined for the type 'DartType'.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.