darwin_eventbus 1.1.0-alpha.4 copy "darwin_eventbus: ^1.1.0-alpha.4" to clipboard
darwin_eventbus: ^1.1.0-alpha.4 copied to clipboard

Synchronous and asynchronous eventbus implementations used by the drawin framework

0
likes
130/ 160
pub points
12%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

19 out of 65 API elements (29.2 %) have documentation comments.

Some symbols that are missing documentation: darwin_eventbus.AsyncEvent, darwin_eventbus.AsyncEvent.AsyncEvent, darwin_eventbus.AsyncEventConsumer, darwin_eventbus.AsyncEventLine, darwin_eventbus.AsyncEventLine.AsyncEventLine.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: Duplicate export.

lib/darwin_eventbus.dart:29:8

   ╷
29 │ export 'src/bus.dart';
   │        ^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/darwin_eventbus.dart

WARNING: Duplicate export.

lib/darwin_eventbus.dart:30:8

   ╷
30 │ export 'src/events.dart';
   │        ^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/darwin_eventbus.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

0
likes
130
pub points
12%
popularity

Publisher

verified publisherexperiments.helight.dev

Synchronous and asynchronous eventbus implementations used by the drawin framework

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (LICENSE)

More

Packages that depend on darwin_eventbus