dartz 0.9.2
dartz: ^0.9.2 copied to clipboard

Functional Programming in Dart. Purify your Dart code using efficient immutable data structures, monads, lenses and other FP tools.

343
likes
90 / 130
pub points
98 %
popularity

We analyzed this package on May 14, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 32 out of 1893 API elements (1.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'List' is deprecated and shouldn't be used. Use a list literal, [], or the List.filled constructor instead.

lib/src/list.dart:29:35

   ╷
29 │   @override List<A> zero() => new List();
   │                                   ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/list.dart

INFO: 'READ' is deprecated and shouldn't be used. Use read instead.

lib/src/unsafe/io.dart:27:67

   ╷
27 │     return new File(io.path).open(mode: io.openForRead ? FileMode.READ : FileMode.WRITE).then((f) => new _RandomAccessFileRef(f));
   │                                                                   ^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/unsafe/io.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=1.24.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

343
likes
90
pub points
98%
popularity

Functional Programming in Dart. Purify your Dart code using efficient immutable data structures, monads, lenses and other FP tools.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

spebbe@gmail.com

License

MIT (LICENSE)

More

Packages that depend on dartz