dartz 0.9.1

Dart native js
Flutter Android iOS web

Functional Programming in Dart. Purify your Dart code using efficient immutable data structures, monads, lenses and other FP tools.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  dartz: ^0.9.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:dartz/dartz.dart';
129
likes
90
pub points
97%
popularity

Functional Programming in Dart. Purify your Dart code using efficient immutable data structures, monads, lenses and other FP tools.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

spebbe@gmail.com

License

MIT (LICENSE)

More

Packages that depend on dartz