dartssh2 2.8.2 copy "dartssh2: ^2.8.2" to clipboard
dartssh2: ^2.8.2 copied to clipboard

SSH and SFTP client written in pure Dart, aiming to be feature-rich as well as easy to use.

110
likes
120/ 160
pub points
93%
popularity

We analyzed this package 4 days ago, and awarded it 120 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

179 out of 443 API elements (40.4 %) have documentation comments.

Some symbols that are missing documentation: dartssh2, dartssh2.DoneFuture.done, dartssh2.OpenSSHBcryptKdfOptions, dartssh2.OpenSSHBcryptKdfOptions.OpenSSHBcryptKdfOptions, dartssh2.OpenSSHBcryptKdfOptions.OpenSSHBcryptKdfOptions.decode.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/ssh_key_pair.dart:666:14

    ╷
666 │       version!,
    │              ^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ssh_key_pair.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/src/ssh_key_pair.dart:667:8

    ╷
667 │       n!,
    │        ^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/ssh_key_pair.dart

failed
Support up-to-date dependencies
20 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
asn1lib ^1.0.0 1.5.3 1.5.3
convert ^3.0.0 3.1.1 3.1.1
meta ^1.1.6 1.15.0 1.15.0
pinenacl ^0.5.0 0.5.1 0.6.0
pointycastle ^3.0.0 3.9.1 3.9.1
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.19.0 1.19.0
js - 0.7.1 0.7.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.5.0` on pinenacl does not support the stable version `0.6.0`, that was published 22 days ago.

When pinenacl is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions pinenacl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 2 errors:

  • UNDEFINED_FUNCTION - lib/src/algorithm/ssh_cipher_type.dart:99:15 - The function 'AESEngine' isn't defined.
  • UNDEFINED_FUNCTION - lib/src/algorithm/ssh_cipher_type.dart:104:25 - The function 'AESEngine' isn't defined.

Run dart pub downgrade and then dart analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

110
likes
120
pub points
93%
popularity

Publisher

verified publisherterminal.studio

SSH and SFTP client written in pure Dart, aiming to be feature-rich as well as easy to use.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

asn1lib, convert, meta, pinenacl, pointycastle

More

Packages that depend on dartssh2