dartins 0.2.1+1
dartins: ^0.2.1+1 copied to clipboard

Dart js
Flutter web

Cordova/Phonegap plugin definitions for use in Dart projects

2
likes
55 / 110
pub points
25 %
popularity

We analyzed this package on Feb 26, 2021, and awarded it 55 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:2:54

  ╷
2 │ <p><a href="https://cordova.apache.org/">Cordova</a>/<a href="http://phonegap.com/">PhoneGap</a> plugin definitions for use in Dart projects.</p>
  │                                                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 476 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime native

Because:

  • package:dartins/dartins.dart that imports:
  • package:dartins/src/code_push.dart that imports:
  • package:node_interop/util.dart that imports:
  • package:node_interop/node.dart that imports:
  • package:node_interop/timers.dart that imports:
  • package:js/js.dart that imports:
  • dart:js
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

lib/src/admob.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/admob_pro.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
js>=0.6.0 <0.7.00.6.20.6.3
node_interop>=1.0.0 <1.1.01.0.31.2.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=1.0.0 <1.1.0` on node_interop does not support the latest published version `1.2.1`

pubspec.yaml:13:17

   ╷
13 │   node_interop: ">=1.0.0 <1.1.0"
   │                 ^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

2
likes
55
pub points
25%
popularity

Cordova/Phonegap plugin definitions for use in Dart projects

Homepage

Documentation

API reference

Uploader

nathankerr@gmail.com

License

BSD (LICENSE)

Dependencies

js, node_interop

More

Packages that depend on dartins