dartdap 0.6.1
dartdap: ^0.6.1 copied to clipboard

LDAP v3 client library for Dart. Supports basic LDAP operations, add, delete, search, modify against any LDAP v3 compliant server.

5
likes
120 / 130
pub points
73 %
popularity

We analyzed this package on May 17, 2021, and awarded it 120 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 135 out of 446 API elements (30.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dartdap/dartdap.dart that imports:
  • package:dartdap/src/dartdap/core/core.dart that imports:
  • package:dartdap/src/dartdap/core/search_result.dart that imports:
  • package:dartdap/src/dartdap/core/ldap_result.dart that imports:
  • package:dartdap/src/dartdap/core/ldap_exception.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
asn1lib^1.0.01.0.01.0.0
collection^1.15.01.15.01.15.0
logging^1.0.01.0.11.0.1
petitparser^4.1.04.1.04.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
meta-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Dart 2.12.4.

5
likes
120
pub points
73%
popularity

LDAP v3 client library for Dart. Supports basic LDAP operations, add, delete, search, modify against any LDAP v3 compliant server.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

warren.strange@gmail.com
hoylen@gmail.com

License

BSD (LICENSE)

Dependencies

asn1lib, collection, logging, petitparser

More

Packages that depend on dartdap