dartcord_core 0.3.1 copy "dartcord_core: ^0.3.1" to clipboard
dartcord_core: ^0.3.1 copied to clipboard

Dartcord makes it easy to create discord bots using the Dart programming language

9
likes
100/ 140
pub points
0%
popularity

We analyzed this package 7 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

32 out of 73 API elements (43.8 %) have documentation comments.

Some symbols that are missing documentation: dartcord, dartcord.Channel.guild, dartcord.Channel.id, dartcord.Channel.name, dartcord.Channel.type.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dartcord_core/dartcord_core.dart that imports:
  • package:dartcord_core/src/client.dart that imports:
  • package:web_socket_channel/io.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: The operand can't be null, so the condition is always 'false'.

lib/src/util/helpers/message_embed.dart:31:9

   ╷
31 │     if (footer != null) {
   │         ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/util/helpers/message_embed.dart

WARNING: The operand can't be null, so the condition is always 'false'.

lib/src/util/helpers/message_embed.dart:38:9

   ╷
38 │     if (author != null) {
   │         ^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/util/helpers/message_embed.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^0.13.5 0.13.6 1.2.1
web_socket_channel ^2.2.0 2.4.5 2.4.5
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
http_parser - 4.0.2 4.0.2
meta - 1.14.0 1.14.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.3.3.

Check the analysis log for details.

9
likes
100
pub points
0%
popularity

Publisher

verified publishersjensen.dev

Dartcord makes it easy to create discord bots using the Dart programming language

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

http, web_socket_channel

More

Packages that depend on dartcord_core