dart_vlc 0.4.0 copy "dart_vlc: ^0.4.0" to clipboard
dart_vlc: ^0.4.0 copied to clipboard

discontinuedreplaced by: media_kit
PlatformLinuxWindows

Flutter audio / video playback, broadcast & recording library for Windows & Linux. Based on libvlc.

248
likes
140/ 160
pub points
90%
popularity

We analyzed this package 6 days ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: dart_vlc,
    • contains a version property, and,
    • does not contain a publish_to property.

pubspec.yaml from the repository defines publish_to, thus, we are unable to verify the package is published from here.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: LGPL-2.1.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

161 out of 202 API elements (79.7 %) have documentation comments.

Some symbols that are missing documentation: channel, channel.kPlayerCreateHWND, channel.kPlayerRegisterTexture, channel.kPlayerUnregisterTexture, dart_vlc.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Windows
  • ✓ Linux

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:dart_vlc/dart_vlc.dart that declares support for platforms: Windows, Linux.
Package does not support platform `iOS`.

Because:

  • package:dart_vlc/dart_vlc.dart that declares support for platforms: Windows, Linux.
Package does not support platform `macOS`.

Because:

  • package:dart_vlc/dart_vlc.dart that declares support for platforms: Windows, Linux.
Package does not support platform `Web`.

Because:

  • package:dart_vlc/dart_vlc.dart that declares support for platforms: Windows, Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
audio_video_progress_bar ^0.11.0 0.11.0 2.0.3
dart_vlc_ffi ^0.2.0+1 0.2.0+1 0.2.0+1
flutter flutter 0.0.0 0.0.0
path ^1.8.2 1.9.0 1.9.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
ffi - 2.1.2 2.1.2
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.0` on audio_video_progress_bar does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions audio_video_progress_bar to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

248
likes
140
pub points
90%
popularity

Publisher

unverified uploader

Flutter audio / video playback, broadcast & recording library for Windows & Linux. Based on libvlc.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

LGPL-2.1 (license)

Dependencies

audio_video_progress_bar, dart_vlc_ffi, flutter, path

More

Packages that depend on dart_vlc