dart_tinydtls 3.1.0 copy "dart_tinydtls: ^3.1.0" to clipboard
dart_tinydtls: ^3.1.0 copied to clipboard

Dart ffi bindings to the tinydtls library. Provides wrappers for both a DTLS client and server.

3
likes
100/ 140
pub points
16%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

71 out of 82 API elements (86.6 %) have documentation comments.

Some symbols that are missing documentation: dart_tinydtls.TinyDTLS.dtls_ec_key_asn1_from_uint32, dart_tinydtls.TinyDTLS.dtls_ecdh_pre_master_secret, dart_tinydtls.TinyDTLS.dtls_ecdsa_create_sig, dart_tinydtls.TinyDTLS.dtls_ecdsa_create_sig_hash, dart_tinydtls.TinyDTLS.dtls_ecdsa_generate_key.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dart_tinydtls/dart_tinydtls.dart that imports:
  • package:dart_tinydtls/src/ffi/generated_bindings.dart that imports:
  • dart:ffi
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 8 issues. Showing the first 2:

WARNING: The value of the field '_constraints' isn't used.

lib/src/dtls_event.dart:302:33

    ╷
302 │   final _DescriptionConstraints _constraints;
    │                                 ^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/dtls_event.dart

INFO: The argument type 'int' isn't related to 'String'.

lib/src/client.dart:511:39

    ╷
511 │       _dtlsClient._connections.remove(_context.address);
    │                                       ^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/client.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.16.0 1.18.0 1.18.0
ffi ^1.1.2 1.2.1 2.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.1.2` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

3
likes
100
pub points
16%
popularity

Publisher

verified publishernamib.me

Dart ffi bindings to the tinydtls library. Provides wrappers for both a DTLS client and server.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

collection, ffi

More

Packages that depend on dart_tinydtls