dart_table 0.0.2 copy "dart_table: ^0.0.2" to clipboard
dart_table: ^0.0.2 copied to clipboard

Flutter data table with selection, sorting, filtering, and pagination. Also supports split view.

7
likes
120/ 140
pub points
22%
popularity

We analyzed this package 17 hours ago, and awarded it 120 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

513 out of 525 API elements (97.7 %) have documentation comments.

Some symbols that are missing documentation: dart_table, dart_table.DartTable, dart_table.DartTable.DartTable, dart_table.DartTable.borderRadius, dart_table.DartTable.decoration.

10/10 points: Package has an example and has no issues with screenshots

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
split_view ^3.2.1 3.2.1 3.2.1
syncfusion_flutter_datagrid ^23.1.43 23.2.7 25.1.40
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
syncfusion_flutter_core - 23.2.7 25.1.40
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^23.1.43` on syncfusion_flutter_datagrid does not support the stable version `24.1.41`.

Try running dart pub upgrade --major-versions syncfusion_flutter_datagrid to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

7
likes
120
pub points
22%
popularity
screenshot

Publisher

verified publishermohesu.com

Flutter data table with selection, sorting, filtering, and pagination. Also supports split view.

Homepage
Repository (GitHub)
View/report issues

Topics

#flutter-datagrid #flutter-table #data-table #datagrid #table

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, split_view, syncfusion_flutter_datagrid

More

Packages that depend on dart_table