dart_posix 0.1.0
dart_posix: ^0.1.0 copied to clipboard

Dart native
Flutter Android iOS

Exposes the POSIX api on OSx and Linux

0
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Jan 19, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 16 API elements (25.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_posix/posix.dart that imports:
  • package:dart_posix/src/libc/getuid.dart that imports:
  • package:dart_posix/src/libc/libc.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ffi0.1.30.1.30.1.3

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
0%
popularity

Exposes the POSIX api on OSx and Linux

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

bsutton@noojee.com.au

License

MIT (LICENSE)

Dependencies

ffi

More

Packages that depend on dart_posix