dart_plaid 3.0.0 icon indicating copy to clipboard operation
dart_plaid: ^3.0.0 copied to clipboard

A Plaid financial data API library for Dart developers (https://plaid.com)

2
likes
120/ 140
pub points
1%
popularity

We analyzed this package 31 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 1150 out of 18483 API elements (6.2 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/generated/plaid_service.swagger.dart:15165:16

      ╷
15165 │   final dynamic? name;
      │                ^
      ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/generated/plaid_service.swagger.dart

INFO: The '?' is unnecessary because 'dynamic' is nullable without it.

lib/generated/plaid_service.swagger.dart:15249:14

      ╷
15249 │       dynamic? name,
      │              ^
      ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/generated/plaid_service.swagger.dart

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
chopper^6.0.06.0.06.0.0
collection^1.15.01.17.11.17.1
json_annotation^4.4.04.8.04.8.0
meta^1.7.01.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.10.02.10.0
http-0.13.50.13.5
http_parser-4.0.24.0.2
logging-1.1.11.1.1
path-1.8.31.8.3
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Dart 2.19.0.

2
likes
120
pub points
1%
popularity

Publisher

unverified uploader

A Plaid financial data API library for Dart developers (https://plaid.com)

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.BSD-3-Clause (LICENSE)

Dependencies

chopper, collection, json_annotation, meta

More

Packages that depend on dart_plaid