dart_mpd 0.3.2 copy "dart_mpd: ^0.3.2" to clipboard
dart_mpd: ^0.3.2 copied to clipboard

a dart package which implements the MPD protocol. https://www.musicpd.org/

3
likes
130/ 160
pub points
72%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

123 out of 392 API elements (31.4 %) have documentation comments.

Some symbols that are missing documentation: dart_mpd, dart_mpd.MpdClient, dart_mpd.MpdClient.MpdClient, dart_mpd.MpdClient.connection, dart_mpd.MpdClientException.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dart_mpd/dart_mpd.dart that imports:
  • package:dart_mpd/src/connection_details.dart that imports:
  • package:platform/platform.dart that imports:
  • package:platform/src/interface/local_platform.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 44 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/models/config.freezed.dart:162:17

    ╷
162 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/config.freezed.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/models/count.freezed.dart:130:17

    ╷
130 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/models/count.freezed.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.17.1 1.19.0 1.19.0
file ^6.1.4 6.1.4 7.0.0
freezed_annotation ^2.2.0 2.4.1 2.4.1
json_annotation ^4.8.0 4.9.0 4.9.0
platform ^3.1.0 3.1.5 3.1.5
Transitive dependencies
Package Constraint Compatible Latest
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^6.1.4` on file does not support the stable version `7.0.0`.

Try running dart pub upgrade --major-versions file to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

3
likes
130
pub points
72%
popularity

Publisher

unverified uploader

a dart package which implements the MPD protocol. https://www.musicpd.org/

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, file, freezed_annotation, json_annotation, platform

More

Packages that depend on dart_mpd