dart_gov_fbi 0.1.1 copy "dart_gov_fbi: ^0.1.1" to clipboard
dart_gov_fbi: ^0.1.1 copied to clipboard

This SDK provides easy access to the FBI's public APIs. This allows you to easily access the FBI's data on wanted criminals, missing persons, and more, with Dart.

12
likes
160/ 160
pub points
0%
popularity

We analyzed this package 11 hours ago, and awarded it 160 pub points (of a possible 160):

partial
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

Issue tracker URL doesn't exist.

At the time of the analysis https://github.com/babincc/flutter_workshop/issues?q=is%3Aissue+is%3Aopen+label%3A%22package%3A+dart_gov_fbi%22 was unreachable. Make sure that the website is reachable via HEAD requests.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

179 out of 285 API elements (62.8 %) have documentation comments.

Some symbols that are missing documentation: api_fields, api_fields.ApiFields.additionalData, api_fields.ApiFields.additionalInfo, api_fields.ApiFields.ageMax, api_fields.ApiFields.ageMin.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.17.0 1.19.0 1.19.0
http ^1.1.0 1.2.1 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
http_parser - 4.1.0 4.1.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 1.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Dart 3.4.4.

Check the analysis log for details.

12
likes
160
pub points
0%
popularity

Publisher

verified publisherhexcat.dev

This SDK provides easy access to the FBI's public APIs. This allows you to easily access the FBI's data on wanted criminals, missing persons, and more, with Dart.

Repository (GitHub)
View/report issues

Topics

#fbi #crime

Documentation

API reference

Funding

Consider supporting this project:

www.buymeacoffee.com
paypal.me
venmo.com

License

MIT (license)

Dependencies

collection, http

More

Packages that depend on dart_gov_fbi