dart_extensionz 6.3.2 copy "dart_extensionz: ^6.3.2" to clipboard
dart_extensionz: ^6.3.2 copied to clipboard

A set of Dart extensions I use in various projects. Including Boolean, DateTime extensions and more.

1
likes
140/ 160
pub points
54%
popularity

We analyzed this package 2 days ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

205 out of 326 API elements (62.9 %) have documentation comments.

Some symbols that are missing documentation: dart_extensionz, dart_extensionz.Cardinal.initials, dart_extensionz.DateTimeExtension.operator +, dart_extensionz.DateTimeExtension.operator -, dart_extensionz.DateTimeExtension.operator <.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:dart_extensionz/dart_extensionz.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 20 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/src/boolean_extension.dart:1:1

  ╷
1 │ part of dart_extensionz;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/boolean_extension.dart

INFO: The part-of directive uses a library name.

lib/src/datetime_extension.dart:1:1

  ╷
1 │ part of dart_extensionz;
  │ ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/datetime_extension.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
intl ^0.18.1 0.18.1 0.19.0
Transitive dependencies
Package Constraint Compatible Latest
clock - 1.1.1 1.1.1
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.1` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

1
likes
140
pub points
54%
popularity

Publisher

verified publishermj12358.dev

A set of Dart extensions I use in various projects. Including Boolean, DateTime extensions and more.

Repository (GitHub)
View/report issues

Topics

#dart #extension

Documentation

API reference

Funding

Consider supporting this project:

www.buymeacoffee.com

License

BSD-3-Clause (LICENSE)

Dependencies

intl

More

Packages that depend on dart_extensionz