dart_discord 0.0.21
dart_discord: ^0.0.21 copied to clipboard

A Dart wrapper to interact with the Discord API.

0
likes
45 / 130
pub points
23 %
popularity

We analyzed this package on May 8, 2021, and awarded it 45 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 13 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_discord/discord_dart.dart that imports:
  • dart:isolate
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: Unused import: 'dart:collection'.

lib/discord_dart.dart:5:8

  ╷
5 │ import 'dart:collection';
  │        ^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/discord_dart.dart

INFO: Unused import: 'dart:isolate'.

lib/discord_dart.dart:7:8

  ╷
7 │ import 'dart:isolate';
  │        ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/discord_dart.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
httpany0.12.20.13.3
logging^0.11.3+20.11.41.0.1
w_transport^3.2.83.2.83.2.8
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.1.0
async-2.6.12.6.1
charcode-1.2.01.2.0
cli_repl-0.2.20.2.2
clock-1.1.01.1.0
collection-1.15.01.15.0
colorize-2.0.03.0.0
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.16.1.0
fluri-1.3.02.0.0
glob-1.2.02.0.1
http_parser-3.1.44.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-0.9.71.0.0
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
package_config-1.9.32.0.0
package_resolver-1.0.101.0.10
path-1.8.01.8.0
pedantic-1.11.01.11.0
quiver-2.1.53.0.1
sass-1.32.81.32.12
sockjs_client-0.3.50.3.5
sockjs_client_wrapper-1.1.01.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
w_common-1.20.41.20.4
watcher-0.9.7+151.0.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.3+2` on logging does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions logging to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.0.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

0
likes
45
pub points
23%
popularity

A Dart wrapper to interact with the Discord API.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

dylan.ogle6601@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

http, logging, w_transport

More

Packages that depend on dart_discord