dart_discord 0.0.21

discord.dart #

A Dart wrapper to interact with the Discord API.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  dart_discord: ^0.0.21

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:dart_discord/discord_dart.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
28
Overall:
Weighted score of the above. [more]
34
Learn more about scoring.

We analyzed this package on Nov 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Platform components identified in package: io, isolate.

Health issues and suggestions

Document public APIs. (-1 points)

13 out of 13 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/discord_dart.dart. (-1.99 points)

Analysis of lib/discord_dart.dart reported 4 hints:

line 5 col 8: Unused import: 'dart:collection'.

line 7 col 8: Unused import: 'dart:isolate'.

line 8 col 8: Unused import: 'package:logging/logging.dart'.

line 9 col 8: Unused import: 'package:w_transport/w_transport.dart'.

Fix lib/src/dart_discord/Client.dart. (-1.99 points)

Analysis of lib/src/dart_discord/Client.dart reported 4 hints:

line 8 col 7: Don't explicitly initialize variables to null.

line 10 col 14: Unnecessary new keyword.

line 27 col 32: Avoid const keyword.

line 28 col 5: Unnecessary new keyword.

Format lib/src/dart_discord/API.dart.

Run dartfmt to format lib/src/dart_discord/API.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: http.

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and dart_discord.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
http any 0.12.0+2
logging ^0.11.3+2 0.11.3+2
w_transport ^3.2.8 3.2.8
Transitive dependencies
args 1.5.2
async 2.4.0
charcode 1.1.2
cli_repl 0.2.0+1
collection 1.14.12
colorize 2.0.0
dart2_constant 1.0.2+dart2
fluri 1.2.8
glob 1.2.0
http_parser 3.1.3
intl 0.15.8 0.16.0
js 0.6.1+1
matcher 0.12.6
meta 1.1.8
mime 0.9.6+3
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
package_resolver 1.0.10
path 1.6.4
pedantic 1.8.0+1
quiver 2.1.2+1
sass 1.23.7
sockjs_client 0.3.5
sockjs_client_wrapper 1.0.14
source_maps 0.10.8
source_span 1.5.5
stack_trace 1.9.3
stream_transform 0.0.20 1.0.0
string_scanner 1.0.5
term_glyph 1.1.0
tuple 1.0.3
typed_data 1.1.6
w_common 1.20.1
watcher 0.9.7+13