dart_dev 3.6.4
dart_dev: ^3.6.4 copied to clipboard

Centralized tooling for Dart projects. Consistent interface across projects. Easily configurable.

2
likes
80 / 130
pub points
68 %
popularity

We analyzed this package on May 6, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 79 out of 141 API elements (56.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_dev/dart_dev.dart that imports:
  • package:dart_dev/src/tools/webdev_serve_tool.dart that imports:
  • package:dart_dev/src/utils/run_process_and_ensure_exit.dart that imports:
  • package:dart_dev/src/utils/ensure_process_exit.dart that imports:
  • package:dart_dev/src/utils/exit_process_signals.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.39.0 <0.42.00.41.21.5.0
args^1.5.21.6.02.1.0
async^2.3.02.6.12.6.1
build_runner^1.7.01.11.12.0.2
completion^0.2.1+10.2.31.0.0
glob^1.1.71.2.02.0.1
io^0.3.30.3.51.0.0
logging^0.11.3+20.11.41.0.1
path^1.6.21.8.01.8.0
pedantic^1.7.01.11.01.11.0
pub_semver^1.4.21.4.42.0.0
pubspec_parse^0.1.40.1.81.0.0
stack_trace^1.9.31.10.01.10.0
yaml^2.1.162.2.13.1.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.021.0.0
build-1.6.22.0.1
build_config-0.4.51.0.0
build_daemon-2.1.103.0.0
build_resolvers-1.5.32.0.1
build_runner_core-6.1.77.0.0
built_collection-5.0.05.0.0
built_value-8.0.58.0.5
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.3.00.3.0
clock-1.1.01.1.0
code_builder-3.7.04.0.0
collection-1.15.01.15.0
convert-3.0.03.0.0
crypto-3.0.13.0.1
dart_style-1.3.122.0.1
file-5.2.16.1.0
fixnum-1.0.01.0.0
graphs-0.2.02.0.0
http_multi_server-2.2.03.0.1
http_parser-4.0.04.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-4.0.14.0.1
meta-1.3.01.3.0
mime-1.0.01.0.0
node_interop-1.2.12.0.1
node_io-1.2.02.0.0
package_config-1.9.32.0.0
pool-1.5.01.5.0
shelf-1.1.11.1.1
shelf_web_socket-0.2.4+11.0.1
source_span-1.8.11.8.1
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-0.1.1+31.0.0
typed_data-1.3.01.3.0
watcher-1.0.01.0.0
web_socket_channel-1.2.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 10 issues. Showing the first 2:

The constraint `>=0.39.0 <0.42.0` on analyzer does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.5.2` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Dart 2.12.4.

2
likes
80
pub points
68%
popularity

Publisher

workiva.com

Centralized tooling for Dart projects. Consistent interface across projects. Easily configurable.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

analyzer, args, async, build_runner, completion, glob, io, logging, path, pedantic, pub_semver, pubspec_parse, stack_trace, yaml

More

Packages that depend on dart_dev