dart_brotli 0.0.3 copy "dart_brotli: ^0.0.3" to clipboard
dart_brotli: ^0.0.3 copied to clipboard

A brotli encoder/decoder for Dart.

0
likes
90/ 140
pub points
0%
popularity

We analyzed this package 4 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL doesn't exist.

At the time of the analysis https://github.com/linkkader/brotli_dart/blob/main/example/lib/dart_brotli_example.dart was unreachable. Make sure that the website is reachable via HEAD requests.

Repository URL doesn't exist.

At the time of the analysis https://github.com/linkkader/brotli_dart was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: dart_brotli,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 18 API elements (22.2 %) have documentation comments.

Some symbols that are missing documentation: dart_brotli.Brotli, dart_brotli.Brotli.Brotli, dart_brotli.Brotli.compress, dart_brotli.Brotli.decompress, dart_brotli.Brotli.init.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Supports 0 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

These platforms are not supported:

Package not compatible with platform Android

Because:

  • package:dart_brotli/dart_brotli.dart that imports:
  • package:dart_brotli/src/dart_brotli_base.dart that imports:
  • dart:cli
Package not compatible with platform iOS

Because:

  • package:dart_brotli/dart_brotli.dart that imports:
  • package:dart_brotli/src/dart_brotli_base.dart that imports:
  • dart:cli
Package not compatible with platform Windows

Because:

  • package:dart_brotli/dart_brotli.dart that imports:
  • package:dart_brotli/src/dart_brotli_base.dart that imports:
  • dart:cli
Package not compatible with platform Linux

Because:

  • package:dart_brotli/dart_brotli.dart that imports:
  • package:dart_brotli/src/dart_brotli_base.dart that imports:
  • dart:cli
Package not compatible with platform macOS

Because:

  • package:dart_brotli/dart_brotli.dart that imports:
  • package:dart_brotli/src/dart_brotli_base.dart that imports:
  • dart:cli
Package not compatible with platform Web

Because:

  • package:dart_brotli/dart_brotli.dart that imports:
  • package:dart_brotli/src/dart_brotli_base.dart that imports:
  • package:ffi/ffi.dart that imports:
  • package:ffi/src/utf16.dart that imports:
  • dart:ffi
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

WARNING: Unused import: 'dart:io'.

lib/dart_brotli.dart:6:8

  ╷
6 │ import 'dart:io';
  │        ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/dart_brotli.dart

WARNING: Unused import: 'dart:cli'.

lib/src/dart_brotli_base.dart:2:8

  ╷
2 │ import 'dart:cli';
  │        ^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/dart_brotli_base.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^2.0.1 2.1.2 2.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

0
likes
90
pub points
0%
popularity

Publisher

unverified uploader

A brotli encoder/decoder for Dart.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

ffi

More

Packages that depend on dart_brotli