dart_board_core 0.9.16+7 copy "dart_board_core: ^0.9.16+7" to clipboard
dart_board_core: ^0.9.16+7 copied to clipboard

Feature Framework for Flutter. Provides a kernel that allows feature encapsulation, isolation and integration.

0.9.16+7 #

  • Update a dependency to the latest release.

0.9.16+6 #

  • Update a dependency to the latest release.

0.9.16+5 #

  • Update a dependency to the latest release.

0.9.16+4 #

  • Update a dependency to the latest release.

0.9.16+3 #

  • Update a dependency to the latest release.

0.9.16+2 #

  • Update a dependency to the latest release.

0.9.16+1 #

  • Update a dependency to the latest release.

0.9.16 #

  • TEST: verify findFeature code works.
  • REFACTOR: moved widgets to dart_board_widgets.
  • REFACTOR: remove unused.
  • FIX: another test.
  • FIX: clean up yamls and working towards improved chat.
  • FIX: fixed dependency loading case where duplicates might have been.
  • FIX: delete unused code.
  • FIX: fix appendroute when from root path.
  • FIX: root target wasn't inflating correctly.
  • FIX: routes get brought to front if requested again.
  • FIX: better 404 (that can return home!!, thanks nav 2.0).
  • FIX: fix up the Chart, now responsive and no longer using pre-release.
  • FIX: remove problems from repo (warnings).
  • FIX: features come from last install if changing (e.g. implementation.
  • FIX: theme fixes for the space-clock/bg.
  • FIX: bugs.
  • FIX: adding tests.
  • FIX: made features a required parameter, non-nullable.
  • FIX: fixed dependency_overrides back in place.
  • FIX: adding tests and coverage.
  • FIX: improvements to example.
  • FEAT: adding more add2app (pigeons and some Android API).
  • FEAT: new and improved spacex example.
  • FEAT: Feature Gate widget and Page Decoration.
  • FEAT: breaking dart board supporting widgets into new project.
  • FEAT: dep chart can include/exclude integration features now.
  • FEAT: layered graph view of dependencies.
  • FEAT: updated entry point.
  • FEAT: tracking + firebase analytics.
  • FEAT: plugin code is nearing completion.
  • FEAT: support for featureOverrides in the DartBoard widget.
  • FEAT: example for particles.
  • FEAT: change notifier builder.
  • FEAT: adding firebase remote config.
  • DOCS: improved.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.

0.9.15+2 #

  • FIX: clean up yamls and working towards improved chat.

0.9.15+1 #

  • Update a dependency to the latest release.

0.9.15 #

  • REFACTOR: moved widgets to dart_board_widgets.
  • FEAT: breaking dart board supporting widgets into new project.
  • FEAT: new and improved spacex example.
  • DOCS: improved.

0.9.14+1 #

  • REFACTOR: remove unused.
  • FIX: delete unused code.
  • FIX: fix appendroute when from root path.
  • FIX: root target wasn't inflating correctly.

0.9.14 #

  • FIX: routes get brought to front if requested again.
  • FIX: better 404 (that can return home!!, thanks nav 2.0).
  • FIX: fix up the Chart, now responsive and no longer using pre-release.
  • FEAT: plugin code is nearing completion.
  • FEAT: adding more add2app (pigeons and some Android API).
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.
  • CHORE: publish packages.

0.9.13 #

  • FEAT: plugin code is nearing completion.
  • FEAT: adding more add2app (pigeons and some Android API).

0.9.12+2 #

  • FIX: routes get brought to front if requested again.
  • FIX: better 404 (that can return home!!, thanks nav 2.0).

0.9.12+1 #

  • FIX: fix up the Chart, now responsive and no longer using pre-release.
  • CHORE: publish packages.

0.9.12 #

  • FEAT: tracking + firebase analytics.

0.9.11 #

  • FIX: bugs.
  • FEAT: support for featureOverrides in the DartBoard widget.

0.9.10 #

  • FIX: fixed dependency loading case where duplicates might have been.
  • FEAT: adding firebase remote config.

0.9.9 #

  • TEST: verify findFeature code works.
  • FIX: improvements to example.
  • FEAT: example for particles.

0.9.8 #

  • FIX: another test.
  • FIX: adding tests.
  • FIX: adding tests and coverage.
  • FEAT: updated entry point.
  • FEAT: Feature Gate widget and Page Decoration.

0.9.7 #

  • FIX: fixed dependency_overrides back in place.
  • FIX: made features a required parameter, non-nullable.
  • FEAT: change notifier builder.
  • CHORE: publish packages.
  • CHORE: publish packages.

0.9.6+1 #

  • FIX: fixed dependency_overrides back in place.
  • FIX: made features a required parameter, non-nullable.

0.9.6 #

  • FEAT: change notifier builder.

0.9.0 #

  • Initial Release

0.9.1 #

  • Fixed the README.md for pub.dev

0.9.2 #

  • Wrong website in the README

0.9.3 #

  • Doing what is required for 130/130 pub points
    • minimal, no-deps example in dart_board_core
    • fixed formatting in 1 file
    • fix package description

0.9.4 #

  • Introduced BuildConvertor widget for casting builder functions E.g. Data->ViewModel

0.9.5 #

  • Introduced Convertor Widget to handle VM generation

0.9.6 #

  • Introduced ChangeNotifier.builder((ctx, val)={});
8
likes
130
pub points
2%
popularity

Publisher

verified publisherdart-board.io

Feature Framework for Flutter. Provides a kernel that allows feature encapsulation, isolation and integration.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

dart_board_widgets, flutter, intl, logging

More

Packages that depend on dart_board_core