dart_azure_cosmosdb 1.0.0 copy "dart_azure_cosmosdb: ^1.0.0" to clipboard
dart_azure_cosmosdb: ^1.0.0 copied to clipboard

dart_azure_cosmosdb offers interaction with the Azure CosmosDB SQL-API.

1
likes
160/ 160
pub points
46%
popularity

We analyzed this package 2 days ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

229 out of 240 API elements (95.4 %) have documentation comments.

Some symbols that are missing documentation: dart_azure_cosmosdb, dart_azure_cosmosdb.CosmosDb, dart_azure_cosmosdb.PermissionMode, dart_azure_cosmosdb.PermissionMode.PermissionMode, dart_azure_cosmosdb.PermissionMode.value.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
crypto ^3.0.3 3.0.3 3.0.3
http ^1.1.0 1.2.1 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
http_parser - 4.1.0 4.1.0
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Dart 3.4.3.

Check the analysis log for details.

1
likes
160
pub points
46%
popularity

Publisher

unverified uploader

dart_azure_cosmosdb offers interaction with the Azure CosmosDB SQL-API.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

crypto, http

More

Packages that depend on dart_azure_cosmosdb