dart_amqp 0.1.4
dart_amqp: ^0.1.4 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Dart AMQP client implementing protocol version 0.9.1

11
likes
60 / 110
pub points
80 %
popularity

We analyzed this package on Feb 27, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 67 out of 237 API elements (28.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:dart_amqp/dart_amqp.dart that imports:
  • package:dart_amqp/src/client.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: Don't type annotate initializing formals.

lib/src/exceptions/channel_exception.dart:9:7

  ╷
9 │       String this.message, int this.channel, ErrorType this.errorType);
  │       ^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/exceptions/channel_exception.dart

INFO: Don't type annotate initializing formals.

lib/src/exceptions/channel_exception.dart:9:28

  ╷
9 │       String this.message, int this.channel, ErrorType this.errorType);
  │                            ^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/exceptions/channel_exception.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
logging^0.11.3+20.11.41.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.3+2` on logging does not support the latest published version `1.0.0`

pubspec.yaml:10:12

   ╷
10 │   logging: ^0.11.3+2
   │            ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

11
likes
60
pub points
80%
popularity

Dart AMQP client implementing protocol version 0.9.1

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

achilleas.imap.mbox@gmail.com

License

MIT (LICENSE)

Dependencies

logging

More

Packages that depend on dart_amqp