dart_alsa 0.0.3 copy "dart_alsa: ^0.0.3" to clipboard
dart_alsa: ^0.0.3 copied to clipboard

Dart FFI Binding to the ALSA sound library

1
likes
50/ 140
pub points
18%
popularity

We analyzed this package 6 days ago, and awarded it 50 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

3 out of 3208 API elements (0.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: alsa_generated_bindings, alsa_generated_bindings.ALSA, alsa_generated_bindings.ALSA.a64l, alsa_generated_bindings.ALSA.abort, alsa_generated_bindings.ALSA.abs.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Linux

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:dart_alsa/alsa_generated_bindings.dart that declares support for platforms: Linux.
Package does not support platform `iOS`.

Because:

  • package:dart_alsa/alsa_generated_bindings.dart that declares support for platforms: Linux.
Package does not support platform `Windows`.

Because:

  • package:dart_alsa/alsa_generated_bindings.dart that declares support for platforms: Linux.
Package does not support platform `macOS`.

Because:

  • package:dart_alsa/alsa_generated_bindings.dart that declares support for platforms: Linux.
Package does not support platform `Web`.

Because:

  • package:dart_alsa/alsa_generated_bindings.dart that declares support for platforms: Linux.
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 9249 issues. Showing the first 2:

ERROR: Array dimensions must be positive numbers.

lib/alsa_generated_bindings.dart:26855:21

      ╷
26855 │   @ffi.Array.multi([0])
      │                     ^
      ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/alsa_generated_bindings.dart

WARNING: The value of the field '_val_' isn't used.

lib/alsa_generated_bindings.dart:26148:33

      ╷
26148 │   external ffi.Array<ffi.Int32> _val_;
      │                                 ^^^^^
      ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/alsa_generated_bindings.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
ffi ^1.0.0 1.2.1 2.1.2
tuple ^2.0.0 2.0.2 2.0.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.0` on ffi does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions ffi to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.0.

Check the analysis log for details.

1
likes
50
pub points
18%
popularity

Publisher

verified publishermanichord.com

Dart FFI Binding to the ALSA sound library

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

ffi, tuple

More

Packages that depend on dart_alsa