daily_flutter 0.16.0-beta.1 copy "daily_flutter: ^0.16.0-beta.1" to clipboard
daily_flutter: ^0.16.0-beta.1 copied to clipboard

Flutter plugin for Daily. The Daily Client SDK allows you to build video and audio calling into your Flutter applications.

2
likes
100/ 140
pub points
60%
popularity

We analyzed this package 10 hours ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

343 out of 1067 API elements (32.1 %) have documentation comments.

Some symbols that are missing documentation: daily_flutter, daily_flutter.ActiveSpeakerChangedEvent, daily_flutter.ActiveSpeakerChangedEvent.ActiveSpeakerChangedEvent, daily_flutter.ActiveSpeakerChangedEvent.participant, daily_flutter.AppMessageReceivedEvent.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:daily_flutter/daily_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:daily_flutter/daily_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:daily_flutter/daily_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:daily_flutter/daily_flutter.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 148 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/model/call_config.freezed.dart:141:17

    ╷
141 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/model/call_config.freezed.dart

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/model/call_config.freezed.dart:654:17

    ╷
654 │   bool operator ==(dynamic other) {
    │                 ^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/model/call_config.freezed.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.18.0
ffi ^2.0.1 2.1.2 2.1.2
flutter flutter 0.0.0 0.0.0
flutter_plugin_android_lifecycle ^2.0.14 2.0.19 2.0.19
freezed_annotation ^2.2.0 2.4.1 2.4.1
json_annotation ^4.7.0 4.9.0 4.9.0
logging ^1.0.0 1.2.0 1.2.0
meta ^1.3.0 1.11.0 1.14.0
permission_handler ^10.2.0 10.4.5 11.3.1
plugin_platform_interface ^2.1.3 2.1.8 2.1.8
synchronized ^3.0.0+3 3.1.0+1 3.1.0+1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
permission_handler_android - 10.3.6 12.0.5
permission_handler_apple - 9.1.4 9.4.4
permission_handler_platform_interface - 3.12.0 4.2.1
permission_handler_windows - 0.1.3 0.2.1
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^10.2.0` on permission_handler does not support the stable version `11.0.0`.

Try running dart pub upgrade --major-versions permission_handler to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

2
likes
100
pub points
60%
popularity

Publisher

verified publisherdaily.co

Flutter plugin for Daily. The Daily Client SDK allows you to build video and audio calling into your Flutter applications.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

collection, ffi, flutter, flutter_plugin_android_lifecycle, freezed_annotation, json_annotation, logging, meta, permission_handler, plugin_platform_interface, synchronized

More

Packages that depend on daily_flutter