customizable_multiselect_field 1.0.1 copy "customizable_multiselect_field: ^1.0.1" to clipboard
customizable_multiselect_field: ^1.0.1 copied to clipboard

A Flutter package that provides a highly customizable multiselect field.

12
likes
90/ 140
pub points
61%
popularity

We analyzed this package 6 days ago, and awarded it 90 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

23 out of 58 API elements (39.7 %) have documentation comments.

Some symbols that are missing documentation: customizable_multiselect_Field, customizable_multiselect_dialog, customizable_multiselect_dialog.CustomizableMultiselectDialog, customizable_multiselect_dialog.CustomizableMultiselectDialog.CustomizableMultiselectDialog, customizable_multiselect_dialog.CustomizableMultiselectDialog.customizableMultiselectDialogOptions.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

ERROR: The getter 'caption' isn't defined for the type 'TextTheme'.

lib/widgets/customizable_multiselect_widget.dart:71:31

   ╷
71 │           themeData.textTheme.caption!.copyWith(color: themeData.errorColor),
   │                               ^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/widgets/customizable_multiselect_widget.dart

ERROR: The getter 'errorColor' isn't defined for the type 'ThemeData'.

lib/widgets/customizable_multiselect_widget.dart:71:66

   ╷
71 │           themeData.textTheme.caption!.copyWith(color: themeData.errorColor),
   │                                                                  ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/widgets/customizable_multiselect_widget.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0-nullsafety.4 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

12
likes
90
pub points
61%
popularity

Publisher

unverified uploader

A Flutter package that provides a highly customizable multiselect field.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, flutter

More

Packages that depend on customizable_multiselect_field