customizable_multiselect_field 1.0.1 copy "customizable_multiselect_field: ^1.0.1" to clipboard
customizable_multiselect_field: ^1.0.1 copied to clipboard

A Flutter package that provides a highly customizable multiselect field.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add customizable_multiselect_field

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  customizable_multiselect_field: ^1.0.1

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:customizable_multiselect_field/customizable_multiselect_flutter.dart';
import 'package:customizable_multiselect_field/models/customizable_multiselect_dialog_options.dart';
import 'package:customizable_multiselect_field/models/customizable_multiselect_widget_options.dart';
import 'package:customizable_multiselect_field/models/data_source.dart';
import 'package:customizable_multiselect_field/models/data_source_options.dart';
import 'package:customizable_multiselect_field/utils/extensions/extended-iterable.dart';
import 'package:customizable_multiselect_field/widgets/customizable_multiselect_Field.dart';
import 'package:customizable_multiselect_field/widgets/customizable_multiselect_dialog.dart';
import 'package:customizable_multiselect_field/widgets/customizable_multiselect_widget.dart';
12
likes
90
pub points
64%
popularity

Publisher

unverified uploader

A Flutter package that provides a highly customizable multiselect field.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

collection, flutter

More

Packages that depend on customizable_multiselect_field