cure 0.1.0-nullsafety.0 icon indicating copy to clipboard operation
cure: ^0.1.0-nullsafety.0 copied to clipboard

outdated

A library for Dart developers which contains some useful tools and extensions: Signalr, MessagePack, CRC, HTTP, EventSource, WebSocket, etc.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add cure

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  cure: ^0.1.0-nullsafety.0

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:cure/convert.dart';
import 'package:cure/core.dart';
import 'package:cure/crypto.dart';
import 'package:cure/http.dart';
import 'package:cure/signalr.dart';
import 'package:cure/signalr_message_pack.dart';
import 'package:cure/sse.dart';
import 'package:cure/ws.dart';
5
likes
0
pub points
68%
popularity

Publisher

verified publisher iconyanshouwang.dev

A library for Dart developers which contains some useful tools and extensions: Signalr, MessagePack, CRC, HTTP, EventSource, WebSocket, etc.

Repository (GitHub)
View/report issues

License

Icon for licenses.unknown (LICENSE)

Dependencies

ansicolor, meta, pedantic, string_scanner, tuple

More

Packages that depend on cure