cure 0.0.5 icon indicating copy to clipboard operation
cure: ^0.0.5 copied to clipboard

A library for Dart developers which contains some useful tools and extensions: Signalr, MessagePack, CRC, HTTP, EventSource, WebSocket, etc.

5
likes
100/ 140
pub points
69%
popularity

We analyzed this package 4 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 279 out of 647 API elements (43.1 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Prefer typing uninitialized variables and fields.

lib/src/signalr/http_client.dart:101:7

    ╷
101 │   var content;
    │       ^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/signalr/http_client.dart

INFO: 'await' applied to 'Object', which is not a 'Future'.

lib/src/signalr/http_connection.dart:383:21

    ╷
383 │       final token = await _accessTokenFactory();
    │                     ^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/src/signalr/http_connection.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
ansicolor^1.1.11.1.12.0.1
pedantic^1.9.21.11.11.11.1
string_scanner^1.0.51.2.01.2.0
tuple^1.0.31.0.32.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.17.01.17.0
matcher-0.12.130.12.13
meta-1.8.01.8.0
path-1.8.21.8.2
quiver-2.1.53.1.0
source_span-1.9.11.9.1
stack_trace-1.11.01.11.0
term_glyph-1.2.11.2.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^1.1.1 on ansicolor does not support the stable version 2.0.1.

Try running dart pub upgrade --major-versions ansicolor to update the constraint.

The constraint ^1.0.3 on tuple does not support the stable version 2.0.0.

Try running dart pub upgrade --major-versions tuple to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.8.1 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

5
likes
100
pub points
69%
popularity

Publisher

verified publisher iconyanshouwang.dev

A library for Dart developers which contains some useful tools and extensions: Signalr, MessagePack, CRC, HTTP, EventSource, WebSocket, etc.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

ansicolor, pedantic, string_scanner, tuple

More

Packages that depend on cure