cupertino_range_slider 1.0.1
cupertino_range_slider: ^1.0.1 copied to clipboard

Flutter Android iOS Linux macOS web Windows

Widget is a slider that help you to choose a range from a set of values.

4
likes
100 / 110
pub points
83 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 100 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 13 API elements (76.9 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/cupertino_range_slider.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0
collection-1.15.0-nullsafety.31.15.0
meta-1.3.0-nullsafety.31.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

4
likes
100
pub points
83%
popularity

Widget is a slider that help you to choose a range from a set of values.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

mahmed8003@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on cupertino_range_slider