crow_annotation 0.0.3 copy "crow_annotation: ^0.0.3" to clipboard
crow_annotation: ^0.0.3 copied to clipboard

Set of utils annotations which will save you the pain of writing boring code.

1
likes
120/ 140
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

33 out of 34 API elements (97.1 %) have documentation comments.

Some symbols that are missing documentation: crow_annotation.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

WARNING: Doc directive 'marco' is unknown.

lib/crow_annotation.dart:230:9

    ╷
230 │   /// {@marco crow.annotation.equals}
    │         ^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/crow_annotation.dart

WARNING: Doc directive 'marco' is unknown.

lib/crow_annotation.dart:293:9

    ╷
293 │   /// {@marco crow.annotation.hashCode}
    │         ^^^^^
    ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/crow_annotation.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
meta ^1.8.0 1.14.0 1.14.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

1
likes
120
pub points
0%
popularity

Publisher

unverified uploader

Set of utils annotations which will save you the pain of writing boring code.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

meta

More

Packages that depend on crow_annotation