crisp 0.3.1 copy "crisp: ^0.3.1" to clipboard
crisp: ^0.3.1 copied to clipboard

Connect with Crisp Chat, register a user to chat (or not) and render a chat widget.

28
likes
110/ 140
pub points
90%
popularity

We analyzed this package 39 hours ago, and awarded it 110 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

18 out of 28 API elements (64.3 %) have documentation comments.

Some symbols that are missing documentation: crisp, crisp_view, crisp_view.CRISP_BASE_URL, crisp_view.CrispView.onLinkPressed, main.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:crisp/crisp.dart that imports:
  • package:crisp/crisp_view.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:crisp/crisp.dart that imports:
  • package:crisp/crisp_view.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:crisp/crisp.dart that imports:
  • package:crisp/crisp_view.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:crisp/crisp.dart that imports:
  • package:crisp/crisp_view.dart that imports:
  • package:flutter_inappwebview/flutter_inappwebview.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

WARNING: Duplicate import.

lib/models/main.dart:5:8

  ╷
5 │ import 'user.dart';
  │        ^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/models/main.dart

INFO: 'canLaunch' is deprecated and shouldn't be used. Use canLaunchUrl instead.

lib/crisp_view.dart:118:23

    ╷
118 │             if (await canLaunch(url)) {
    │                       ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/crisp_view.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_inappwebview ^5.3.2 5.8.0 6.0.0
url_launcher ^6.0.9 6.2.6 6.2.6
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_web_plugins - 0.0.0 0.0.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
url_launcher_android - 6.3.2 6.3.2
url_launcher_ios - 6.3.0 6.3.0
url_launcher_linux - 3.1.1 3.1.1
url_launcher_macos - 3.2.0 3.2.0
url_launcher_platform_interface - 2.3.2 2.3.2
url_launcher_web - 2.3.1 2.3.1
url_launcher_windows - 3.1.1 3.1.1
vector_math - 2.1.4 2.1.4
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.3.2` on flutter_inappwebview does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions flutter_inappwebview to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.

28
likes
110
pub points
90%
popularity

Publisher

verified publisheroiluna.com

Connect with Crisp Chat, register a user to chat (or not) and render a chat widget.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_inappwebview, url_launcher

More

Packages that depend on crisp