crimson 0.3.1 copy "crimson: ^0.3.1" to clipboard
crimson: ^0.3.1 copied to clipboard

Fast, efficient and easy-to-use JSON parser and serializer for Dart.

112
likes
130/ 140
pub points
67%
popularity

We analyzed this package 7 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

60 out of 61 API elements (98.4 %) have documentation comments.

Some symbols that are missing documentation: generator.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
analyzer ^5.13.0 5.13.0 6.5.0
build ^2.4.0 2.4.1 2.4.1
source_gen ^1.3.2 1.5.0 1.5.0
Transitive dependencies
Package Constraint Compatible Latest
_fe_analyzer_shared - 61.0.0 68.0.0
args - 2.5.0 2.5.0
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
convert - 3.1.1 3.1.1
crypto - 3.0.3 3.0.3
dart_style - 2.3.2 2.3.6
file - 7.0.0 7.0.0
glob - 2.1.2 2.1.2
logging - 1.2.0 1.2.0
meta - 1.15.0 1.15.0
package_config - 2.1.0 2.1.0
path - 1.9.0 1.9.0
pub_semver - 2.1.4 2.1.4
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
watcher - 1.1.0 1.1.0
yaml - 3.1.2 3.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^5.13.0` on analyzer does not support the stable version `6.0.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

112
likes
130
pub points
67%
popularity

Publisher

verified publishersimc.dev

Fast, efficient and easy-to-use JSON parser and serializer for Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

analyzer, build, source_gen

More

Packages that depend on crimson