cresce_api 1.20.2 copy "cresce_api: ^1.20.2" to clipboard
cresce_api: ^1.20.2 copied to clipboard

Api client for Cresce Api

0
likes
130/ 160
pub points
0%
popularity

We analyzed this package 42 hours ago, and awarded it 130 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

240 out of 794 API elements (30.2 %) have documentation comments.

Some symbols that are missing documentation: cresce.api, cresce.api.AccountDetailModel, cresce.api.AccountDetailModel.balance, cresce.api.AccountDetailModel.date, cresce.api.AccountDetailModel.description.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:cresce_api/api.dart that imports:
  • dart:io
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 71 issues. Showing the first 2:

INFO: The part-of directive uses a library name.

lib/api/accounts_api.dart:10:1

   ╷
10 │ part of cresce.api;
   │ ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/api/accounts_api.dart

INFO: The part-of directive uses a library name.

lib/api/appointments_api.dart:10:1

   ╷
10 │ part of cresce.api;
   │ ^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/api/appointments_api.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^1.1.0 1.2.1 1.2.1
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.19.0 1.19.0
http_parser - 4.0.2 4.0.2
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2
web - 0.5.1 0.5.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Dart 3.4.3.

Check the analysis log for details.

0
likes
130
pub points
0%
popularity

Publisher

unverified uploader

Api client for Cresce Api

Repository

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http

More

Packages that depend on cresce_api