crates_api 1.0.0 copy "crates_api: ^1.0.0" to clipboard
crates_api: ^1.0.0 copied to clipboard

Simple Dart package to access the crates.io api.

0
likes
100/ 140
pub points
0%
popularity

We analyzed this package 11 hours ago, and awarded it 100 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

5 out of 387 API elements (1.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: authors, authors.AuthorMeta, authors.AuthorMeta.AuthorMeta, authors.AuthorMeta.AuthorMeta.fromJson, authors.AuthorMeta.names.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: The variable name 'crates_cnt' isn't a lowerCamelCase identifier.

lib/types/v1/categories/index.dart:25:19

   ╷
25 │     required this.crates_cnt,
   │                   ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/types/v1/categories/index.dart

INFO: The variable name 'created_at' isn't a lowerCamelCase identifier.

lib/types/v1/categories/index.dart:26:19

   ╷
26 │     required this.created_at,
   │                   ^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/types/v1/categories/index.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
http ^0.13.5 0.13.6 1.2.1
json_annotation ^4.7.0 4.9.0 4.9.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
collection - 1.18.0 1.18.0
http_parser - 4.0.2 4.0.2
meta - 1.15.0 1.15.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.13.5` on http does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.

0
likes
100
pub points
0%
popularity

Publisher

unverified uploader

Simple Dart package to access the crates.io api.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

http, json_annotation

More

Packages that depend on crates_api