cr_calendar 1.2.1 copy "cr_calendar: ^1.2.1" to clipboard
cr_calendar: ^1.2.1 copied to clipboard

Awesome calendar with customizations, range picking and event showing.

101
likes
120/ 140
pub points
90%
popularity

We analyzed this package 5 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

99 out of 129 API elements (76.7 %) have documentation comments.

Some symbols that are missing documentation: cr_calendar, cr_calendar.CalendarEventModel, cr_calendar.CalendarEventModel.CalendarEventModel, cr_calendar.CalendarEventModel.begin, cr_calendar.CalendarEventModel.end.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

INFO: 'describeEnum' is deprecated and shouldn't be used. Use the `name` getter on enums instead. This feature was deprecated after v3.14.0-2.0.pre.

lib/src/widgets/default_weekday_widget.dart:20:11

   ╷
20 │           describeEnum(day).substring(0, 1).toUpperCase(),
   │           ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/default_weekday_widget.dart

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
intl ^0.18.1 0.18.1 0.19.0
jiffy ^6.2.1 6.2.1 6.3.1
scrollable_positioned_list ^0.3.8 0.3.8 0.3.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.18.1` on intl does not support the stable version `0.19.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.22.0, Dart 3.4.0.

Check the analysis log for details.