cpub 0.0.4
cpub: ^0.0.4 copied to clipboard

A sample command-line application.

0
likes
50 / 110
pub points
0 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
0 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 13 API elements (15.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:cpub/cpub.dart that imports:
  • package:process_run/cmd_run.dart that imports:
  • package:process_run/src/flutterbin_cmd.dart that imports:
  • package:process_run/src/process_cmd.dart that imports:
  • package:process_run/process_run.dart that imports:
  • package:process_run/src/dev_process_run.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

bin/cpub.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/utils.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
args^1.6.01.6.02.0.0
process_run^0.11.0+20.11.2+80.12.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.2.01.2.0
collection-1.15.01.15.0
io-1.0.01.0.0
meta-1.3.01.3.0
path-1.8.01.8.0
pub_semver-2.0.02.0.0
source_span-1.8.11.8.1
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.6.0` on args does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions args to update the constraint.

The constraint `^0.11.0+2` on process_run does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions process_run to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
50
pub points
0%
popularity

A sample command-line application.

Homepage

Documentation

API reference

Uploader

li3cheng3@gmail.com

License

MIT (LICENSE)

Dependencies

args, process_run

More

Packages that depend on cpub