country_picker 2.0.25 copy "country_picker: ^2.0.25" to clipboard
country_picker: ^2.0.25 copied to clipboard

A flutter package to select a country from a list of countries.

337
likes
130/ 140
pub points
99%
popularity

We analyzed this package 5 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

39 out of 61 API elements (63.9 %) have documentation comments.

Some symbols that are missing documentation: country_picker, country_picker.Country.displayNameNoE164Cc, country_picker.Country.e164Key, country_picker.Country.e164Sc, country_picker.Country.Country.from.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/country_list_bottom_sheet.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/src/country_list_view.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.18.0 1.18.0 1.18.0
flutter flutter 0.0.0 0.0.0
universal_io ^2.2.2 2.2.2 2.2.2
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
typed_data - 1.3.2 1.3.2
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

337
likes
130
pub points
99%
popularity

Publisher

unverified uploader

A flutter package to select a country from a list of countries.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

collection, flutter, universal_io

More

Packages that depend on country_picker