couchbase_lite 2.8.1
couchbase_lite: ^2.8.1 copied to clipboard

Flutter Android iOS

Flutter plugin for Couchbase Lite Community Edition, an embedded lightweight, noSQL database with live synchronization and offline support on Android and iOS.

30
likes
85 / 110
pub points
73 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 85 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:42:31

   ╷
42 │ <p>Setup beer-sample database <a href="http://127.0.0.1:8091/">Local Couchbase Server</a>:</p>
   │                               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 98 out of 434 API elements (22.6 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:couchbase_lite/couchbase_lite.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 11 issues. Showing the first 2:

INFO: 'pushAttributeKeyFilter' is deprecated and shouldn't be used. use pushAttributeFilters instead for multiple filter support.

lib/src/replicator_configuration.dart:64:9

   ╷
64 │     if (pushAttributeKeyFilter != null && pushAttributeValuesFilter != null) {
   │         ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/replicator_configuration.dart

INFO: 'pushAttributeValuesFilter' is deprecated and shouldn't be used. use pushAttributeFilters instead for multiple filter support.

lib/src/replicator_configuration.dart:64:43

   ╷
64 │     if (pushAttributeKeyFilter != null && pushAttributeValuesFilter != null) {
   │                                           ^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/replicator_configuration.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
built_collection>=2.0.0 <5.0.04.3.25.0.0
built_value>=5.5.5 <8.0.07.1.08.0.0
crypto^2.1.32.1.53.0.0
encrypt^4.0.04.1.04.1.0
flutterflutter0.0.00.0.0
hex^0.1.20.1.20.1.2
meta>=1.1.6 <2.0.01.3.01.3.0
password_hash^2.0.02.0.02.0.0
uuid>=2.0.4 <3.0.02.2.23.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.0.0
asn1lib-0.8.10.8.1
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
fixnum-0.10.111.0.0
matcher-0.12.100.12.10
path-1.8.01.8.0
pointycastle-2.0.12.0.1
quiver-2.1.53.0.0
sky_engine-0.0.990.0.99
stack_trace-1.10.01.10.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `>=2.0.0 <5.0.0` on built_collection does not support the stable version `5.0.0`, that was published 22 days ago.

When built_collection is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions built_collection to update the constraint.

The constraint `>=5.5.5 <8.0.0` on built_value does not support the stable version `8.0.0`, that was published 22 days ago.

When built_value is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions built_value to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

30
likes
85
pub points
73%
popularity

Flutter plugin for Couchbase Lite Community Edition, an embedded lightweight, noSQL database with live synchronization and offline support on Android and iOS.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

weltbr01@gmail.com

License

MIT (LICENSE)

Dependencies

built_collection, built_value, crypto, encrypt, flutter, hex, meta, password_hash, uuid

More

Packages that depend on couchbase_lite